Back to overview
Resolved

Tenant users are unable to access dashboard

Jun 29, 2026 at 9:17pm UTC
Affected services
Public Website
Tenant Portal
Payment Processing

Resolved
Jun 29, 2026 at 11:19pm UTC

A fix has been implemented. The tenant dashboard should be accessible now.

Created
Jun 29, 2026 at 9:17pm UTC

Tenant users are currently unable to access their dashboard. We are currently working on fixing this issue and the dashboard should be accessible soon.