Payments experiencing degraded performance
Resolved
Feb 12 at 01:16am HST
We’re back! payment services should be up and running. Thanks for bearing with us.
Affected services
Updated
Feb 11 at 07:35am HST
We are still working with our payment processing partners to resolve this issue.
Updates would be communicated duly.
Affected services
Updated
Feb 11 at 03:03am HST
We have identifies the root cause of the issue and are working to fully restore services affected.
We urge users to use the offline payments feature to make payments for now.
Affected services
Created
Feb 11 at 01:28am HST
We’re investigating an issue with payments processing system that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services