Back to overview
Degraded

Tenant portal is unavailable

Jan 10 at 09:18am HST

Resolved
Jan 10 at 11:25am HST

The issue has been rectified. All services are functional. Thank you for your patience.

Updated
Jan 10 at 10:26am HST

We have identified the root cause of the issue. It would be resolved within 15-30 minutes. Thank you for your patience.

Created
Jan 10 at 09:18am HST

A small amount of tenants have logged tenant portal inaccessibility. We are currently looking into this.
Updates would be communicated duly.