Back to overview
Resolved
Payments are currently unavailable
Jan 10, 2026 at 1:09am UTC
Resolved
Jan 10, 2026 at 1:35am UTC
Issue has been rectified and the affected services are back to normal.
Thank you for your patience.
Affected services
Updated
Jan 10, 2026 at 1:23am UTC
Our team is still working to solve this. Thank you for your patience
Affected services
Created
Jan 10, 2026 at 1:09am UTC
A small percentage of users are experiencing payment status invalidation. We are currently working on it.
Affected services